Have a question?

CONTACT US

Constraint Checker Plugin for QGIS

Constraint Checker Plugin

Constraint Checker is a plugin for QGIS that allows users to check whether an area intersects with existing PostGIS layers.

The plugin enables users to quickly verify compliance with regulations or zoning

The Constraint Checker plugin was kindly funded by Dartmoor National Park Authority.

Installation

Constraint Checker is available from the official QGIS plugin repository. To install the Constraint Checker plugin in in QGIS, simply select Plugins > Manage and Install Plugins... from the main menu. The Plugin Manager dialog will appear. In its left-hand panel, select Get more. Within the Search box now type constraint checker. Select the Constraint Checker plugin from the list and click Install plugin.

Using Constraint Checker

To use Constraint Checker, you need to first ensure that there is at least one PostGIS connection set up in your QGIS. You can then configure the Constraint Checker plugin by Plugins > Constraint Checker > Edit Configuration.

A new window will appear. From PostGIS Connection drop-down menu, select the connection you want to base your constraint on and cick on New Constraint.

Fill in the constraint details based on your PostGIS table and constraint information. You can choose multiple column to be reported by using a comma seperator. Repeat the same if you'd like to add more than one constraints from other tables or PostGIS connections.

Example of the Constraint Checker plugin configuration

You can use import and export option to better manage and share your configurations.

To do a check, you can either use a free-hand polygon to define your area of interest or select an existing area feature from one of the layers in QGIS canvas.

You can give your query a Reference Number and the result should appear in a table. Output can be exported as a csv file for reporting in other software packages.

Example of the Constraint Checker plugin output